Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Copying Sketches

colin_dalycolin_daly OS Professional Posts: 37 ✭✭
edited May 2017 in Community Support
When going to copy sketches, I have begun to get the error:  "library version mismatch" .  Untill yesterday I never had this problem....

Answers

  • jakeramsleyjakeramsley Member, Moderator, Onshape Employees, Developers Posts: 602
    This is due to the recent release.  We are in the process of upgrading documents to the latest version, at which point this shouldn't happen.
    Jake Ramsley

    Director of Quality Engineering & Release Manager              onshape.com
  • george_dwyergeorge_dwyer Member Posts: 1
    I'm guessing this will be why derived sketches aren't working for me either. Do you know when the documents will be upgraded?
  • rbaekrbaek Moderator, Onshape Employees, Developers Posts: 77
    I'm guessing this will be why derived sketches aren't working for me either. Do you know when the documents will be upgraded?
    Documents should have been upgraded by now. If you're still experiencing issues, please report the issue via the Feedback form.
  • Reece_IsaacReece_Isaac Member Posts: 36 ✭✭
    Same problem for me today, have feedback just now. Interesting that this is still recurring.
  • Reece_IsaacReece_Isaac Member Posts: 36 ✭✭
    So it seems that branching has something to do with this.
  • lanalana Onshape Employees Posts: 531
    @Reece_Isaac
    Indeed, when  branch is created from an old version it is not in an upgraded state. We'll have that fixed, but for now
    please file an issue with support - 
    viar Feedback button in ? menu.  They'll help you. 
  • Tony_C_Tony_C_ Member Posts: 260 PRO
    Just got this today when trying to paste a sketch into @NeilCooke 's featurescript beam profile maker.
  • Josy_LaJosy_La Member Posts: 82 ✭✭
    Same here. I was okay until yesterday but this morning I can't copy sketches.
  • alejo_vicentealejo_vicente Member Posts: 1 EDU
    Hi, I had the same issue. A partner did a document , and a branch in it. Then , he shared me that document and now i wanted to paste a sketch entitie from another document of my repertory and says this error
  • Jake_RosenfeldJake_Rosenfeld Moderator, Onshape Employees, Developers Posts: 1,560
    @alejo_vicente
    It sounds like one of the documents is not upgraded to the current version.  Can you either post the URL of both docs here (if they are public) or put in a support request to look at this for you?
    Jake Rosenfeld - Modeling Team
Sign In or Register to comment.