Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Newbie question on dimensions for export

skyvoyagerskyvoyager Member Posts: 1
I know this is a newbie question...Sorry!

I have units set to inches in Onshape.  When I export parts via STL and import them into Cura or Simple3D, they come in as mm (for instance, a 2 in x 2 in x 2 in cube comes in as 2 mm x 2 mm x 2 mm).

What am I doing wrong?

Thanks!

Answers

  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,466 PRO
    I don't have experience in Cura or Simple3D but Geomagic Design prompts me to choose units while importing stuff.
    Check the settings in the programs where you are importing, maybe there is possibility to choose units. It's just scaling. 
    //rami
  • michael3424michael3424 Member Posts: 622 ✭✭✭
    Does STL format default to metric units (mm)?

    Mike
  • gerry_filbygerry_filby Member Posts: 2
    Had the same issue, although I'm not sure it's a 1 to 1 inch to mm conversion issue.  When I switched my sketch units to metric and re-exported the STL, Cura was able to make sense of it.  Maybe this is an STL generation issue - I've exported countless STLs from SolidWorks to Cura and not seen this issue.
  • andrew_troupandrew_troup Member, Mentor Posts: 1,584 ✭✭✭✭
    edited May 2015
    STL units (within the format) are arbitrary.

    What this means is that they are just numbers, with no unit specified within the file, hence it makes no difference what your export settings are: it is only the import package which can assign units.
  • gerry_filbygerry_filby Member Posts: 2
    So I did some digging to help others that follow - SolidWorks provides a scaling option when it exports to STL.  The default is to convert inch numerators to millimeter - i.e. multiply the numbers by 25.4.  Hence "it just works" in Cura.  So you have 2 options in OnShape - convert your sketch dims to millimeters (less good in my opinion) .... or ... in Cura click on your model and in the left bottom corner the middle icon allows you to "scale" - change "1" to "25.4" and you're good to go.  Maybe OnShape can emulate what SolidWorks does when exporting to STL.
  • kenneth_9kenneth_9 Member Posts: 1
    I had the same issue as skyvoyager.  When I exported my STL I selected inches (because that is the unit I used to dimension my model) when I opened the file with the printer software the model looked tiny.  Some quick measurements told me that it was 3mm wide instead of 3in.  This would all make sense with the following answer
    STL units (within the format) are arbitrary.

    What this means is that they are just numbers, with no unit specified within the file, hence it makes no difference what your export settings are: it is only the import package which can assign units.
    except when, just for fun, I exported the STL and selected millimeters as my unit to export.  When I opened the new file with the printer software the model was the correct size.  If the previous statement were correct (and it seems like it would be the best and easiest solution) then the files should be identical no matter what unit I select when I export. 

    What does my selection mean when I select units for STL export and how do the selections modify the dimension data exported?
  • jerome_burgojerome_burgo Member Posts: 1
    Cura reads those arbitrary numbers in milimeters. When you select mm for export, onshape converts you dimensions from in to mm and then saves those arbitrary numbers. Cura reads then can read the size appropriately.
Sign In or Register to comment.