Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Help with Mac/Onshape problem

gene_russellgene_russell Member Posts: 12
I had been using Onshape about a year ago and wanted to pick it up again. Now Onshape won't display anything in the display area. I can sketch and see my new geometry when I open the document on an iPad but nothing is visible on my Mac Pro. I have tried three browsers, Onshape support and nvidia support with no resolution.My system is...
Mac Pro 4.1 OS X El Capitan 10.11.6 nvidia GeForce 120
Any suggestions much appreciated.

Answers

  • Paul_J_PremakumarPaul_J_Premakumar Member, Onshape Employees Posts: 196
    Hi Gene,

    -  Onshape relies on WebGL for displaying the graphics. Can you please confirm that your browser is able to run WebGL applications. You can determine this by visiting either of these pages : https://get.webgl.org/ or https://cad.onshape.com/check. You should see some graphics on either page.

    - Is the issue document specific or impacting all documents. For example : Are you able to see graphics from other documents? Open a public document and see if the graphics renders.

    - Can you check the browser's debug console and see if there are any errors being reported? 

  • gene_russellgene_russell Member Posts: 12
    Thanks Paul. Both links show that my browser is compatible and display graphics. I prefer Chrome but I have tried Safari and Firefox. The behavior is the same. All documents do not display. I am using Onshape in free/public so all of my documents are public. I have tried copying tutorial models and creating new geometry. All is invisible. I can open the same documents in my iPad and see the 'invisible' changes I made on the mac pro.
  • gene_russellgene_russell Member Posts: 12
    Oh and I turned on the console in Chrome and there are no errors reported.
  • Jake_RosenfeldJake_Rosenfeld Moderator, Onshape Employees, Developers Posts: 1,646
    Hi @gene_russell

    Really sorry to hear you're having this problem!  Please hit the "Report a bug" button under the "?" menu in a document so that we can investigate what's going on one-on-one.  In your bug report you may want to link this forum post and mention that you already tried the check page.
    Jake Rosenfeld - Modeling Team
  • gene_russellgene_russell Member Posts: 12
    I have already done the "Report a bug". Their recommendation was to update the nvidia drivers. After an hour online with nvidia the tech told me that there are no drivers for 10.11.6. I downloaded two drivers from them that claimed to be for 10.11.6 but each time I ran the pkg it reported that the pkg was for 10.11.6 and I should update to 10.11.6. Software update says that my 10.11.6 is fully up to date. This is frustrating. Am I the only one to have this problem?
  • Paul_J_PremakumarPaul_J_Premakumar Member, Onshape Employees Posts: 196
    Hi Gene,

     Thanks for the response. It is quite possible that the Graphics card / driver doesn't have some of the required features that Onshape requires. It looks like NVidia stopped shipping drivers for the GeForce 120 in 2016. Ask a test, can you try disabling the hardware acceleration in Chrome : http://www.solveyourtech.com/turn-hardware-acceleration-google-chrome/ , this should bypass the graphics card. That said, the performance many not be the best, since it uses a less optimal path for graphics.

    Paul
  • gene_russellgene_russell Member Posts: 12
    I tried turning off acceleration but when I relaunch and try to load Onshape it tells me I have no WebGL. I tried turning it on and off a few times without change. Note I am having the same problem in three different browsers Chrome,Safari, and Firefox. I am told that since this card is stock from Apple that the graphics drivers are supplied/updated as part of OS X system updates.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 5,238
    Can you update to latest OS X? And check that Chrome (64-bit) is fully updated? Not saying that will
    solve your problem but it does sound very odd. And yes, as far as we know you are the only one with this problem. 
    Senior Director, Technical Services, EMEAI
Sign In or Register to comment.