Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

3dConnexion not working again...

Ben_Ben_ OS Professional, Mentor, Developers Posts: 286 PRO
Anyone else having issues with their spacepilot stopping working lately? Mine works fine on Rhino, SaladWorks, MeshMixer etc etc but Onshape in both Chrome and Firefox are not working. I feel like I have been hobbled when I loose this thing....

FYI I downloaded the latest 3DConnexion software and tried a re-install but no go
Rebooted Chrome and Firefox to see if that was it
Rebooted twice did not work
Shut down and waited a few min and started and no go

So I have done the proverbial "have you tried turning off and on again?" 

Comments

  • Ben_Ben_ OS Professional, Mentor, Developers Posts: 286 PRO
    I take some of this back it does not work on Rhino or MeshMixer anymore... ugh
  • Ben_Ben_ OS Professional, Mentor, Developers Posts: 286 PRO
    So a complete uninstall, restart, and re-install worked... strange stuff considering I have done nothing to my computer for a month... Anyhow ignore me. :)
  • MBartlett21MBartlett21 Member, OS Professional, Developers Posts: 1,953 EDU
    Ben_ said:
    SaladWorks
    @Ben_
    Do you mean this: http://www.saladworks.com/
    MB - I make FeatureScripts: View FeatureScripts
  • chrisjh777chrisjh777 Member Posts: 192 ✭✭✭
    @Ben,

    Appears that you have solved your issue.  However I thought I'd share my experience below:

    3dxConnexion not working with Onshape is caused by  3dxService.exe in Windows Startup not loading 3dxNIServer during Windows boot on faster machines.  Works fine on slower machines like my Lenovo Ideapad.

    This is what I have to do each day, when I boot my Dell Precision M4800 laptop:

    1.  Disable 3dxService.exe in Windows Start (found in Task Manager, you only have to do this once).

    2.  Boot Windows and let everything settle.

    3.  Click on the Windows icon in the bottom LH corner of the screen, Type "Start Driver" and hit enter. This executes 3dxService.exe,  ensuring it runs after everything else in the Windows Start Routine.

    Once I perform the daily ritual Steps 2 and 3 described above, 3dConnexion Mouse works fine with Onshape, regardless of driver version.  There appears to be a sequence timing error on fast machines which prevents 3dxNIServer from being loaded during Windows boot.

    3dConnexion in Germany are aware of this issue, because I have been working with them for a permanent fix.  To date and, even with the latest driver issued end May18 , the problem still persists.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 3,838
    @chrisjh777 if I remember right (it's been a while since I dumped Windows in favour of Mac), isn't there a "delayed start" option for Windows services? Have you tried that?

    Director, Technical Services, EMEAI
  • chrisjh777chrisjh777 Member Posts: 192 ✭✭✭
    @NeilCooke

    I looked into the possibility of "reordering" Windows start sequence so that 3dxService.exe started last, but I'm not skilled enough.

    I will google "delayed start" later, when I have time.  In the meantime, my workaround facilitates full use of both of my 3dConnexion mice.  I have one wired to USB and one wireless. 
  • ryan_mcgoldrick47ryan_mcgoldrick47 Member Posts: 69 PRO
    Mine has stopped working this last week no idea why, tried reinstalling too, works fine in solidworks.. 
Sign In or Register to comment.