Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

No preview, no drawing print

thomas_holfordthomas_holford Member Posts: 36
I created an assembly drawing sheet and then used the top left of the screen Chrome "hamburger" menu to access the print menu.
I clicked print, got the Windows print facility screen and a message that said "downloading preview".

After the  message went away, there was no preview. Just a blank page.  I printed the preview anyway and it printed a blank page.

I disabled uBlock in Chrome and tried to print again, with the same result.

Help.


Comments

  • viruviru Member, Developers Posts: 619 ✭✭✭✭
    @thomas_holford , I am using google chrome and Mozilla Firefox browser. In both cases it working fine as shown in below video.


    Can you take screen-shot and send it to Onshape support team.



  • thomas_holfordthomas_holford Member Posts: 36
    Here is a screen print of the "print preview" screen:


  • thomas_holfordthomas_holford Member Posts: 36
    After consulting with a software engineer, I was talked through a little debugging activity.

    I opened the model to the "Assembly 1 Drawing 1" tab.

    I clicked on the Chrome "hamburger" icon at the top left of the screen.

    The print dialog window opened and displayed the message " creating preview", followed by a blank print document.

    The java console displayed the following errors:

    "Failed to load resource: the server responded with a status of 401 (Unauthorized)
    https://127.51.68.120:8181/3dconnexion/nlproxy
    Failed to load resource: net::ERR_CONNECTION_REFUSED
    app.js:9590 document.domain set to onshape.com"

    Does this help anyone figure out why I can't print my On-Shape drawing?

    FYI.  I don't know if this is significant, but "3dconnexion" is my 3D pointing device.
  • shashank_aaryashashank_aarya Member Posts: 265 ✭✭✭
    @thomas_holford I think it would be better if you submit ticket to Onshape support by using  ? menu -> Feedback. Support team will resolve this issue.
  • jon_mcintyrejon_mcintyre Onshape Employees Posts: 56
    Instead of clicking on the Chrome (or browser's) hamburger menu and print, use the hamburger menu inside Onshape, which is located in the upper left, next to the Onshape logo.   The print command in that menu will work for you. 

    The other way to print a drawing is to right-mouse-button click on the drawing tab at the bottom of the window, and choose "Export to PDF", then print the PDF file. 

  • andrew_troupandrew_troup Member, Mentor Posts: 1,629 ✭✭✭✭
    ......

    I clicked on the Chrome "hamburger" icon at the top left of the screen......

    Do you mean top right?
  • john_mcculloughjohn_mccullough Moderator, Onshape Employees Posts: 38

    @thomas_holford, currently drawings tabs use the Print command in the Onshape "hamburger" menu to create a PDF and automatically open it in a new browser tab.

    Users have reported several problems with this process and our plan is to adjust it to match the standard browser print workflow which you seem to be expecting. 
Sign In or Register to comment.