Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:

  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Direct Editing - Copy Hole/Geometry?

Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
This seems basic, but I can't figure out how to copy/duplicate a hole using direct editing in Onshape.  Move Face works to move the hole...but I expected a "copy" or "leave original" checkbox so I could make a copy.  I tried a few other techniques (offset surface (0 offset), transform, split...no luck).

Any techniques on duplicating holes/geometry (collection of selected surfaces)?

Best Answer

Answers

  • konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 939 ✭✭✭✭✭
    face pattern should work, look for transform pattern feature in comunity spotlight shortcut
  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    Thanks for the quick response.  I'm on Enterprise and it's not showing me custom features outside of my enterprise.  I see stuff under "FeatureScript samples", but nothing under Community spotlight and the "Public" option isn't there.  I found your FS through searches, but can't figure out how to add/use it.

    Any ideas?


  • konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 939 ✭✭✭✭✭
    to add the FS you need to open open the document which contains the FS, switch to part studio and pres "plus" button in the top right corner, then select desired FS in the opened dialog.
    here is the original document of the feature:

  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    Thanks!  Got it added now.  Unfortunately it's failing for my geometry.  I think there's a singularity or something.  I'll try some other ideas I had.

    Thanks for your quick responses, and for the nifty FS tool.

  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    Thanks @Jake_Rosenfeld.  I think I had tried the linear face pattern before.  It fails.  There must be something wonky with my geometry...although it's strange that Move Face works but Linear Pattern of same faces fails.
  • billy2billy2 Member, OS Professional, Mentor, Developers Posts: 1,322 PRO
    edited July 25
    @Malcolm_Daniel

    Finding feature scripts is harder than it should be. Perhaps no one realized how many would be created and how useful they'd become. The older the script, the harder it is to find.

    I've been told that a newer solution is forthcoming. I still struggle finding'm.

    I'm adding this hoping to get a better solution sooner than later.


  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    @billy2 .... thanks for the confirmation.  It's funny...I submitted a help ticket about using public FS in Enterprise, and their response was "can't currently be done"...so they didn't even know about the workflow @konstantin_shiriazdanov suggested above (which worked).
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 2,602
    @Malcolm_Daniel - yes, you have to sign in to cad.onshape.com using your enterprise credentials in order to add public FS features
  • philip_thomasphilip_thomas Member, Moderator, Onshape Employees, Developers Posts: 1,374
    @Malcolm_Daniel - Transforming faces works best when the faces are exactly the same at each location.
    There are several ways of making this more robust.
    One workflow says:

    Put a point on a plane at the location of each of the holes in the derived part.
    Use 'Advanced Select' to find all the faces of all the holes and delete them.
    Add a parametric hole in the first location
    Use the feature pattern to replicate the holes to the other locations (or the parametric pattern custom feature if the spacing is irregular).

    Send me an email if you're still struggling.
    Philip.
    Philip Thomas - Onshape
  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    @NeilCooke ... I see now ... public restriction applies to my company domain but not to cad.onshape.com ... thanks.
    How do I get something from public or my Enterprise acct @ cad.onshape.com into my domain (for link or copy)?
  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    @philip_thomas ... thanks ... that's sort of what i did.  I ended up revolving a tool with a sketch that references the original hole/feature, patterned that tool, then did a boolean.

    I still don't understand why the "Move Face" works fine, but Linear Pattern (and several other methods) fail for the same geometry.  I'll work with you offline on it.
  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 2,602
    @Malcolm_Daniel I’m not at a computer right now to check, but I think you right click the document on the documents page and select Transfer Ownership
  • Malcolm_DanielMalcolm_Daniel Member Posts: 57 PRO
    FYI, for the benefit of others, I shared my model with @philip_thomas who ended up filing a bug report.  He also gave me a workaround for the meantime.
  • philip_thomasphilip_thomas Member, Moderator, Onshape Employees, Developers Posts: 1,374
    ^^^ For anyone else - yeah, we think its a bug. The workaround is as follows;
    • Make a transform/copy of the part
    • Delete-face the axial holes
    • Face pattern the cross holes
    • Boolean-Intersect the two parts
    I am going to now go back to the developers and bribe them with coffee and chocolate to get this fixed asap :)
    Philip Thomas - Onshape
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,152 PRO
    Please do, I have similar problem for a long time, Lou filed a report over a year ago at least.
    It only seems to work half the time (literally) Face pattern worked on front chute, but not the rear one, so I had to pattern the sketch instead.



    This one was working up until today when I changed the sheet-metal thickness from .1196" to .1345", the bug reveiled itself, now I have to to  work around and re-mate all the fasteners. :(



    Nowhere near as complex as what he has, but there defiantly is a bug somewhere in face pattern.


Sign In or Register to comment.