Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Incomplete rendering of parts in assembly

edward_petrilloedward_petrillo Member Posts: 41 EDU
While working in a fairly complex assembly, I frequently encounter a situation where several parts are rendered as "ghosts" even after the tab has finished loading.  I have set the tesselation of some but not all parts to "medium' and selected "Use automatic tesselation" on some but not all subassemblies.  The tesselation setting seem to make no difference whether a part is rendered completely or not.  Changing the tesselation on all parts would be quite a chore- many are from linked documents. My graphics performance (462 milllion, 195 million)  is the same as it as always been but the prevalence of this problem seems to have increased.  The change in performance may have coincided with an upgrade to Windows 10 from Windows 7, but all of the browser settings (Chrome) conform to Onshape recommendations.  The document is here:
https://cad.onshape.com/documents/68fd659f4cf18cb89d2a0243/w/3ce02e36ac8d8a5e8938c492/e/55d30a35600015f653e96719

Any suggestions for improving performance?

Comments

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 3,130
    Renders OK for me on a Mac with 51m/103m, but the RAM is taking a bashing. Perhaps @Evan can chime in.
  • EvanEvan Onshape Employees Posts: 58
    @edward_petrillo - I see that two sub-assemblies are marked as "Use best available tessellation" (noted with the diamond icon).  This will force the tessellation quality for those sub-assemblies to their highest level, which may take up the available memory and cause some parts to remain unloaded.  (Those are the parts that appear as translucent boxes.) Setting those sub-assemblies to "Use automatic tessellation setting" may help more tessellation come down for other components.

    In general we may forego loading some parts initially to avoid exceeded the browser's memory limit.  Chrome has fairly restrictive per-tab memory limits, so we will load less in Chrome in the context of larger assemblies.  Firefox has a more liberal limit, so you will find that more parts are loaded immediately.  So you may want to try Firefox out to see if your performance is improved.  (Note: it needs to be the 64-bit variant of Firefox, which is not the standard install for Firefox.)
  • bill_danielsbill_daniels Member Posts: 272 ✭✭✭
    I'm having the same problem in Chrome.  Sometimes all parts render and sometimes a random number of "Ghost boxes" appear which will eventually render if given enough time.  If this is a Chrome memory limit issue, why the variability and why would they eventually render?  Note that I have a 16 GB machine with a NVIDIA 2060 Super with 8GB.
  • john_mcclaryjohn_mcclary Member, Developers Posts: 2,812 PRO
    They will eventually render, the ghost boxes are a means to load a document quicker and let you get to it

    If you zoom in on an area, you will notice those parts take priority and begin to render in quicker.

    If you want to see the whole model in full render, you will need to wait.

    It isn't a limit of ram, I think it has more to do with the Onshape server re-building the un-cashed parts
Sign In or Register to comment.