Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Sweep conditions

Eric_92Eric_92 OS Professional Posts: 19 PRO
I'm stumping myself again. Trying to do a sweep to cut away around a perimeter of a solid. The sketch for the solid is on the top and the cut sketch is coincident at the corner with the main sketch. Can't get a sweep to work. What am I missing...? I've been trying all sorts of things.
Thanks.



Best Answer

Answers

  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,461 PRO
    Hi Eric, you need to select edges as path. If you can make your document public and share the link here I can help you out.
    //rami
  • Eric_92Eric_92 OS Professional Posts: 19 PRO
    Here it is:
    https://cad.onshape.com/documents/ff6d67cd5bdc48b7b5f6eed0/w/fcda994d00aa4e6f92304548/e/31819b296c244489b939967c
    With selecting edges I can't get it to run the full perimeter.

  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,461 PRO
    I will give it a try..
    //rami
  • Eric_92Eric_92 OS Professional Posts: 19 PRO
    Wow thanks, I would have never tried that. Seems like a bit of a bug to me? Kinda non-intuitive. Thanks for your help!
  • 3dcad3dcad Member, OS Professional, Mentor Posts: 2,461 PRO
    What do you guys think @lougallo@jakeramsley @philip_thomas?

    //rami
  • _Ðave__Ðave_ Member, Developers Posts: 712 ✭✭✭✭
    Starting at the endpoint appears logical to me.
  • Eric_92Eric_92 OS Professional Posts: 19 PRO
    Well now I know, but it's not mentioned anywhere that you need to start on an end point - just that you need a path. Seems this feature could use some fleshing out with direction control etc. Just my 2c. I've had some fumbling every time using it.
  • jakeramsleyjakeramsley Member, Moderator, Onshape Employees, Developers Posts: 634
    Sweeps don't have to start on a vertex, but it is good practice to do so.  The sweep path is essentially giving instructions in how to move the profile, but it moves it with respect to the profile.  So when you select the first edge, you are telling the profile to go out that distance and follow the path, rather than moving the profile to the vertex and then go out that distance (effectively following the edges).

    For example, I made a circular profile and a line that goes through it for the path.  The sweep causes the cylinder to be the same height as the path, but doesn't start and end on it.


    When I add a spline that is tangent to both ends, the sweep tries to follow the curvature the best it can at this point, but because it is offset will give unpredictable results


    By having the path start at the profile, it has a much easier time following the path.

    Jake Ramsley

    Director of Quality Engineering & Release Manager              onshape.com
  • andrew_troupandrew_troup Member, Mentor Posts: 1,584 ✭✭✭✭
    Here's how I try to make sense of the way Sweep works in Onshape, armed with the great info from @jakeramsley

    A quick study model verifies which path endpoint "Sweep" uses as the starting point (corresponding to the profile)  when the profile plane lies at an intermediate location along the path.

    I sketch a line through the origin, on the Top plane.
    From the origin, I dimension each endpoint of the line (40 vs 50, per screen capture) so it's "offset" one way relative to the profile plane.



    I then sketch a circle on the Front plane. It's not centered on the origin: it doesn't even overlap the path; so It's also what I call a "remote" profile.

    With that circle as the profile and the line as the path, here's the resulting sweep


    OK: So here's my tentative mental model of what's happening

    When Onshape is asked to sweep a profile, it builds a railway track along the path. It positions a hand-truck at the endpoint along the path NEAREST to the profile plane. (this needs further verification)

    It then erects a temporary cantilever frame from that truck to the profile (the truck and the cantilever are constructed from clear material, so we can't see them).

    It bends up the profile out of solid wire, and attaches it to the invisible frame.

    The wire is heated and it has a coating which produces thick white smoke. The handcart is pushed the full length of the path. The "Sweep" is the volume enclosed by smoke.

    - - -

    The key understanding from what jake wrote is that there is not a firm rule saying you must locate a sweep profile at an entity endpoint, which is why Onshape "Help" doesn't say there is.

    I'm guessing the real reason the OP's sweep didn't work is that the sweep profile intersected itself when it was "remote". 

    I can't verify that because when I try to open his model, I get 
    <<Failed to load document for workspace. Resource does not exist, or you do not have permission to access it.>> Maybe it's no longer public...

    But here's what I mean by "intersected itself":

    If at any point, the smoke doubles back on itself (new smoke is created inside old smoke) then the sweep fails.

    Most modern MCAD sweep routines can cope with certain exceptions, like mitred corners on the path, but in the case of paths with curves, generally tight corners produce problems with large or offset or remote profiles.
  • andrew_troupandrew_troup Member, Mentor Posts: 1,584 ✭✭✭✭
    edited October 2015
    I struck a snag when I tried to verify my guess that the "handtruck" was positioned at the nearest endpoint on the path to the profile plane.

    When I tried to edit the 40mm dimension to 60, the model would not update. 
    Note that every time I double click and bring up the dimension it shows as 60, but reverts to 40 every time I press "Enter"

    (if the graphic is not animating for you, or if the 60mm dimension is illegibly small, RMB and "Open image in new tab" - it's recorded as a twice-thru loop, so it may have timed out before you got to it)



    This has been happening to me regularly for many months, and it's a known, ticketed issue. I'm forced to wonder if it's a browser problem, because if it was an Onshape problem I would have expected it to be resolved by now.

    The fix is easy but (particularly in a complex model and/or slow connection) it's time consuming, and interrupts the train of thought. It requires reloading that browser tab.

    Another reason it's disruptive: If I navigate away from that tab, it seems from my experience that reloading halts. So if I try to make use of the time instead of twiddling my thumbs I am (surreptitiously) thwarted: when I go back to that tab a few minutes later it has STILL not reloaded: if I've waited a bit too long, the session will have timed out and it's back to square one.

    This can be frustrating.
  • andrew_troupandrew_troup Member, Mentor Posts: 1,584 ✭✭✭✭
    So far it seems my supposition is correct: the virtual hand-truck is positioned at the nearest endpoint on the path, in the simple orthogonal case with a single straight line for a path. 

    IOW, when I reloaded the browser tab 60/50 so the profile became offset to the path in the other direction, the sweep proceeded in the reverse sense.

    I need to test other cases, (including 50/50)  but I've run out of time just now.

    TO BE CONTINUED
  • _Ðave__Ðave_ Member, Developers Posts: 712 ✭✭✭✭
    +1 4 Frustrating timing out and reloading paused when navigating away.
Sign In or Register to comment.