Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.

Can we hide mate connectors?

rajendra_bhatrajendra_bhat OS Professional, Mentor Posts: 8 ✭✭
edited July 2016 in Community Support
In assembly, able to hide default mate connectors but not able to hide created mate connectors. which disturbs a lot. Is there a way to hide them..?

Answers

  • billy2billy2 Member, OS Professional, Mentor, Developers, User Group Leader Posts: 1,799 PRO
    Soon, part mate connectors in an assembly will turn off very soon.

    It's a known issue.

  • lougallolougallo Member, Moderator, Onshape Employees, Developers Posts: 1,995
    You can hide them now if you create them in the Assembly. If they are added in the Part Studio you cannot yet. We are working on this.
    Lou Gallo / PD/UX - Support - Community / Onshape, Inc.
  • Ben_Ben_ OS Professional, Mentor, Developers Posts: 290 PRO
  • darren_henrydarren_henry Onshape Employees Posts: 85
    You can hide them now, even if they were created in the PartStudio.  Give it a try.

  • charleycharley OS Professional Posts: 20 ✭✭
    You can hide them now, even if they were created in the PartStudio.  Give it a try.

    How?
  • navnav Member Posts: 258 ✭✭✭✭
    Hi @charley below showing how to hide them, I created some mate connectors in Parts Studio and then another one in Assembly:





    Nicolas Ariza V.
    Indaer -- Aircraft Lifecycle Solutions
  • charleycharley OS Professional Posts: 20 ✭✭
    Thanks.  Also I figured out you can right click on one in the graphics area and click "hide other mate connectors", and then "hide", to get them all quickly.  A "hide mate connectors" option would be even better.
  • billy2billy2 Member, OS Professional, Mentor, Developers, User Group Leader Posts: 1,799 PRO
    Yes charley, I agree.

    'Show all' causes the problem.

    I've asked that 'show all' stop showing mate connectors. Let's see if it get implemented. 

  • gzgz Member Posts: 13
    Uh, has anyone noticed that this bug still exists in the Android app?
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,693 PRO
    you have to hide them all one at a time in app :(

    As a work around: if you open the assembly on a computer and hide them all, they hide in the app as well.
  • gzgz Member Posts: 13
    Even if I hide them manually in the app or in the full browser on the computer, they still show.

    Worse, now certain parts aren't even showing up.  But the connectors do.  There seems to be something badly wrong with assemblies on the Android app.
Sign In or Register to comment.