Welcome to the Onshape forum! Ask questions and join in the discussions about everything Onshape.

First time visiting? Here are some places to start:
  1. Looking for a certain topic? Check out the categories filter or use Search (upper right).
  2. Need support? Ask a question to our Community Support category.
  3. Please submit support tickets for bugs but you can request improvements in the Product Feedback category.
  4. Be respectful, on topic and if you see a problem, Flag it.

If you would like to contact our Community Manager personally, feel free to send a private message or an email.




  • michael_mcclainmichael_mcclain Member Posts: 198 PRO
    I have been using GrabCAD workbench with my SW clients and its not so bad, but there is nothing like true cloud CAD. My colleagues praise it since it has solved many of their issues so far, but they just have no clue how good it can get with a full cloud like Onshape. Even using F360 feels like a half measure when I cant edit a design while someone is accessing it. I'm spoiled with Onshape!
  • homebrewdesignhomebrewdesign Member Posts: 16 ✭✭
    I've been away from Onshape for a little over a year. Just started with a new company last month, and pitched OS to my new boss, but he just signed a 3 year contract with SW in September. Been dead in the water the last 2 days because we forgot to borrow our licenses before we started working from home. SW is supposed to be sending us temporary ones, which is great that they'll do that for us, but still we haven't heard back from them in 2 days.
  • KrzKrz Member, Developers Posts: 68 ✭✭✭
    I fill you pain @homebrewdesign with no access to license server.
    I have extracted CATIA license for 30 days but it will expire April 2nd. I cannot go to office as it is in another European country and some borders are closed.
    But I found solution. I will use anydesk to connect to remote computer at the office (I already use it for some remote activities) then I setup TCP  tunneling in anydesk to redirect port 4085 to CATIA license server at office network. Then on my laptop I setup CATIA to search license on localhost:4085.
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO

    uughhh... no... No it hasn't... 

  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO

    I had to run out to the office this morning because my licences expired, it only lets you check out for a month or so.

    I can't seem to get checking out a lic over VPN to work, so we have to physically haul our computers in and grab the Lic.

    Well, I was working up until SW decided to crash (like normal) but this time it lost it's grip on the license too....
    ugghhh... The server still shows the lic is checked out. So now I have to go in again today. And hopefully resolve this without the dreaded reset of the lic server. Which would mean everyone would have to come in and physically check out a seat again.

    It's only a 3 mile drive for me, but some of them are a good half hour trip.

    Sadly one doesn't have a laptop.. so he has to haul a full size tower in each time.
    And we all just reset our lic checkouts last week...  :s

    What a pain.. The whole company will have to bend because one computer crashed...

  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    edited May 2020
    Nope, they're screwed and will have to come in...  :s

    One good thing. Now I get to work the rest of the day in an Onshape project :)
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    Now everyone is broken...

  • michael3424michael3424 Member Posts: 673 ✭✭✭✭
    Seems like SW would have a better way of working in this situation.  My old CAD software (Alibre) lets you remotely log off of one computer and transfer the license to another and the data acquisition software that I use lets me install versions on both work and home computers or I can log in remotely to the work license server from home and the license will work for 30 days or so before I need to log in to the server again.  Both processes are pretty painles and take a minute or so.  Did SW lose all the good developers to Onshape? >:)
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    I thitk that is exactly what happened. Sw was starting to show decline about the same time onshape went into beta... 
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    Yeay, main assembly is corrupt... happy Wednesday!  

  • NeilCookeNeilCooke Moderator, Onshape Employees Posts: 5,238
    So how long after "Contacting Technical Support" do you get a resolution? :wink:
    Senior Director, Technical Services, EMEAI
  • MBartlett21MBartlett21 Member, OS Professional, Developers Posts: 2,031 EDU

    It was only a possible solution. :D
    mb - draughtsman - also FS author: View FeatureScripts
    IR for AS/NZS 1100
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    I'm sure the first thing they would say is "Oh, we see you're still using 2019, please try upgrading to 2020  :#
  • konstantin_shiriazdanovkonstantin_shiriazdanov Member Posts: 1,221 ✭✭✭✭✭
    edited July 2020
    I'm sure the first thing they would say is "Oh, we see you're still using 2019 ...

  • emagdalenaC2iemagdalenaC2i Member, Developers, Channel partner Posts: 857 ✭✭✭✭✭
    Please, tell the technical support:
    • The SW2019 service pack
    • your cpu
    • RAM
    • graphic card

    Un saludo,

    Eduardo Magdalena                         C2i Change 2 improve                         ☑ ¿Por qué no organizamos una reunión online?  
                                                                         Partner de PTC - Onshape                                     Averigua a quién conocemos en común
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    edited November 2020
    I got lucky,

    It looks like it corrupt a week or so ago when I last saved.
    I've been on other tasks lately so I haven't been in the main install.
    I have another project that was pushed in front of this (yeay it can be done in Onshape!)
    but If I didn't want to check in on this before I changed over to the new Quote, I would have lost it forever in about a week...

    Still Lost a couple hours from the old backup I needed to grab...
    But at least I didn't have to rebuild this and the 10 configurations of it... and all the drawing section views that would have broke.. etc.. 

    Bullet Dodged

  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    edited July 2020
    Déjà vu?

    I like how it says it can't open the file, even though it has been open most of the day and I am trying to same changes to it...
    Stupid SW...

    2 seconds after posting:

    Oh, I guess it decided to go for broke...

    Did it again immediately afterwards. NOW I know what is going on...
    Someone else had the main assembly open in read-only so they could reference a hole location, while I was trying to rename a file in a weldment. This is a know bug with SW for as long as I have been using it. Good to see it still ain't fixed. Not sure what I was expecting...

    Yeay SW Collaboration

  • Evan_ReeseEvan_Reese Member Posts: 2,055 PRO
    Absolutely dripping with sarcasm and I love it.
    Evan Reese / Principal and Industrial Designer with Ovyl
    Website: ovyl.io
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    edited September 2020
    Tried changing configurations in SW.. went to lunch,  came back, I don't think it's doing what it says it is...

  • steve_shubinsteve_shubin Member Posts: 1,061 ✭✭✭✭

    Well we’ve read how your boss wants SolidWorks to be used because I guess the other CAD folk have him coerced him into thinking that SolidWorks is ‘the program’ you must use

    So now you got all the excuse in the world to take loooooooooong lunches


  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
  • Ste_WilsonSte_Wilson Member Posts: 195 EDU
  • alnisalnis Member, Developers Posts: 447 EDU
    I've been learning SolidWorks for university, and I must say, it's been a struggle.

    An allegedly round filleted edge:

    Another filleted edge in a "solid" model, not a surface model:

    A cursed linkage assembly:

    This is just the tip of the iceberg. Other issues I've had:
    - UI elements zipping around in the viewport, completely of their own free will
    - Random features are suppressed when re-opening a document when I am 100% sure I did a rebuild without anything suppressed before saving
    - Can't select some of the entities onscreen
    - Editing child features causes parent features to randomly change selections and break (entering and exiting the parent feature without doing anything fixes this)
    - "Automatic Rebuild" in the configuration table does not always automatically rebuild (took me a while to figure that one out...)
    - Appearance randomization
    - View pings off into infinity sometimes (seems to be correlated with having infinite length lines in sketches)
    - Onscreen gizmos for feature manipulation sometimes don't match what the model actually looks like
    - Endless "unknown error" and "error while saving" pop up dialogs

    Unfortunately, I can't reproduce many of these issues because there isn't a way to step back through each change in history like you can with Onshape.

    I'm sure some of these issues are my fault, but it's still been quite a hassle to try to be productive.

    Student at University of Washington | Get in touch: [email protected] | My personal site: https://alnis.dev | Currently an Onshape intern: [email protected]
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    Solidworks we call 'sometimes works' it's good most of the time but it has a bunch of common bugs. And zero collaboration 
  • alnisalnis Member, Developers Posts: 447 EDU
    Yeah, seems like it's decent enough software as long as you have a good backup scheme, patience, and a solid workstation. Admittedly, I am using an older service pack of 2020-2021, but that's because the web portal for downloading SolidWorks says the education key I purchased over the summer for a 1-year term is invalid (even though it's just been 6 months!). Fortunately, I should be able to upgrade to SP5 now since I just got a new key from the CAD class I'm taking this quarter. Maybe there will be fewer bugs.
    Student at University of Washington | Get in touch: [email protected] | My personal site: https://alnis.dev | Currently an Onshape intern: [email protected]
  • john_mcclaryjohn_mcclary Member, Developers Posts: 3,877 PRO
    Fewer bugz lol that's cute.... 
Sign In or Register to comment.